データセット一覧

JoGo

JoGo RDFは、Joint Open Genome and Omics Platform(JoGo)が主にロングリードシーケンスデータを用いて構築した、ヒトのハプロタイプカタログのRDF版です。JoGoは、タンパク質コード遺伝子のハプロタイプをアミノ酸配列、コード配列、転写産物、遺伝子全体の各レベルでカタログ化し、一塩基バリアント、挿入、欠失の情報とともに提供しています。

データセット仕様

タグ
Genome Human Variation
提供元 Original
登録区分 Submitted
データ提供者
  • JoGo Project
作成者
  • 長﨑正朗九州大学生体防御医学研究所
  • 河合洋介国立遺伝学研究所
  • 守屋勇樹国立遺伝学研究所
公開日 2026-09-03
ライセンス
  • https://creativecommons.org/licenses/by-sa/4.0/deed.en
バージョン Ver. 1.0
ダウンロード /website/ja/download/#jogo
SPARQLエンドポイント https://rdfportal.org/primary/sparql

データセット統計

Triples
1042087006
Subjects
80010024
Properties
47
Objects
174029249
Classes
24

SPARQLクエリ例

例 1

エンドポイントで実行
# Retrieve amino acid-level haplotypes for a given gene symbol
# Order by the number of observed haplotype copies, from highest to lowest

PREFIX jogo: <http://jogo.csml.org/ontology#>
PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX foaf: <http://xmlns.com/foaf/0.1/>

SELECT ?haplotype ?haplotype_id ?length ?count ?page
WHERE {
  VALUES ?symbol { "ALDH2" }

  ?gene a jogo:GeneRegion ;
        rdfs:label ?symbol ;
        jogo:aHaplotype ?haplotype .

  ?haplotype dcterms:identifier ?haplotype_id ;
             jogo:sequenceLength ?length ;
             jogo:totalCount ?count .

  OPTIONAL { ?haplotype foaf:page ?page . }
}
ORDER BY DESC(?count) ?haplotype_id

例 2

エンドポイントで実行
# Count distinct haplotypes at each ATCG level for a given gene
# A: amino acid sequence, T: transcript, C: coding sequence, G: whole gene

PREFIX jogo: <http://jogo.csml.org/ontology#>
PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>

SELECT ?level (COUNT(DISTINCT ?haplotype) AS ?haplotype_count)
WHERE {
  VALUES ?symbol { "ALDH2" }
  VALUES (?level ?predicate) {
    ("A" jogo:aHaplotype)
    ("T" jogo:tHaplotype)
    ("C" jogo:cHaplotype)
    ("G" jogo:gHaplotype)
  }

  ?gene a jogo:GeneRegion ;
        rdfs:label ?symbol .

  OPTIONAL { ?gene ?predicate ?haplotype . }
}
GROUP BY ?level
ORDER BY ?level

例 3

エンドポイントで実行
# Retrieve population-specific counts of amino acid-level haplotypes
# alleleCount represents the number of observed copies, not a proportion

PREFIX jogo: <http://jogo.csml.org/ontology#>
PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
PREFIX dcterms: <http://purl.org/dc/terms/>

SELECT ?haplotype_id ?population_code ?population_label ?count
WHERE {
  VALUES ?symbol { "ALDH2" }

  ?gene a jogo:GeneRegion ;
        rdfs:label ?symbol ;
        jogo:aHaplotype ?haplotype .

  ?haplotype dcterms:identifier ?haplotype_id ;
             jogo:frequency ?frequency .

  ?frequency jogo:population ?population ;
             jogo:alleleCount ?count .

  ?population dcterms:identifier ?population_code ;
              rdfs:label ?population_label .
}
ORDER BY ?population_code DESC(?count) ?haplotype_id

例 4

エンドポイントで実行
# Retrieve missense variants found in coding sequence-level haplotypes of a gene
# Variant annotations and allele frequencies are stored in gene-specific records

PREFIX jogo: <http://jogo.csml.org/ontology#>
PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX gvo: <http://genome-variation.org/resource/gvo#>

SELECT DISTINCT
  ?variant_id ?ref ?alt ?hgvs_c ?hgvs_p ?allele_frequency
WHERE {
  VALUES ?symbol { "ALDH2" }

  ?gene a jogo:GeneRegion ;
        rdfs:label ?symbol ;
        jogo:cHaplotype ?haplotype .

  ?haplotype jogo:hasVariant ?variant .

  ?variant jogo:annotation "missense_variant" ;
           jogo:genomicVariant ?genomic_variant .

  ?genomic_variant dcterms:identifier ?variant_id ;
                   gvo:ref ?ref ;
                   gvo:alt ?alt .

  OPTIONAL { ?variant jogo:hgvsC ?hgvs_c . }
  OPTIONAL { ?variant jogo:hgvsP ?hgvs_p . }
  OPTIONAL { ?variant jogo:alleleFrequency ?allele_frequency . }
}
ORDER BY DESC(?allele_frequency) ?variant_id

例 5

エンドポイントで実行
# Retrieve the combined haplotype and its A, T, C, and G components for each sample haplotype (hp1/hp2), using a sample ID and gene symbol.

PREFIX jogo: <http://jogo.csml.org/ontology#>
PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
PREFIX dcterms: <http://purl.org/dc/terms/>

SELECT DISTINCT
  ?sample_id ?sample_haplotype_id ?combined_id ?a_id ?t_id ?c_id ?g_id
WHERE {
  VALUES ?symbol { "ALDH2" }
  VALUES ?sample_id { "HG02074" }

  ?gene a jogo:GeneRegion ;
        rdfs:label ?symbol ;
        jogo:actgHaplotype ?combined .

  ?combined dcterms:identifier ?combined_id ;
            jogo:aHaplotype ?a ;
            jogo:tHaplotype ?t ;
            jogo:cHaplotype ?c ;
            jogo:gHaplotype ?g ;
            jogo:hasSampleHaplotype ?sample_haplotype .

  ?a dcterms:identifier ?a_id .
  ?t dcterms:identifier ?t_id .
  ?c dcterms:identifier ?c_id .
  ?g dcterms:identifier ?g_id .

  ?sample_haplotype dcterms:identifier ?sample_haplotype_id ;
                    jogo:sample ?sample .

  ?sample dcterms:identifier ?sample_id .
}
ORDER BY ?sample_haplotype_id ?combined_id

スキーマ図

Schema diagram for jogo
Schema diagram for jogo