データセット一覧

fanta.bio

fanta.bio(Functional genome ANnotations with Transcriptional Activities)は、プロモーターやエンハンサーなどのシス制御領域を中心としたゲノム機能アノテーションデータベースです。CAGEデータを用いて同定した制御領域と、細胞・組織ごとの転写活性に、転写因子結合部位やゲノム変異の情報を統合し、遺伝子発現制御の研究を支援します。

データセット仕様

タグ
Genome Human Expression
提供元 Original
登録区分 Submitted
データ提供者
  • 理研生命医科学研究センター生命医科学大容量データ技術研究チーム
作成者
  • 粕川 雄也理研生命医科学研究センター生命医科学大容量データ技術研究チーム
  • 川路英哉東京都医学総合研究所 ゲノム医学研究センター
  • 守屋 勇樹国立遺伝学研究所
公開日 2026-09-03
ライセンス
  • https://creativecommons.org/licenses/by-sa/4.0/deed.en
バージョン Ver. 1.2.1
ダウンロード /website/ja/download/#fantabio
SPARQLエンドポイント https://rdfportal.org/primary/sparql

データセット統計

Triples
630117311
Subjects
179827083
Properties
21
Objects
184580098
Classes
19

SPARQLクエリ例

例 1

エンドポイントで実行
# Retrieve cis-regulatory elements associated with a given gene symbol
# Example: ALDH2 in humans

PREFIX fantao: <http://fanta.bio/ontology/>
PREFIX dct: <http://purl.org/dc/terms/>
PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
PREFIX sio: <http://semanticscience.org/resource/>
PREFIX obo: <http://purl.obolibrary.org/obo/>
PREFIX tax: <http://identifiers.org/taxonomy/>

SELECT DISTINCT ?cre ?cre_id ?cre_name ?activity_class
WHERE {
  VALUES ?symbol { "ALDH2" }

  ?cre a fantao:CisRegulatoryElement ;
       obo:RO_0002162 tax:9606 ;
       dct:identifier ?cre_id ;
       rdfs:label ?cre_name ;
       sio:SIO_000395 ?regulated_entity .

  ?regulated_entity rdfs:label ?symbol .

  OPTIONAL {
    VALUES ?activity_class { fantao:PLA fantao:ELA }
    ?cre a ?activity_class .
  }
}
ORDER BY ?cre_id ?activity_class

例 2

エンドポイントで実行
# Retrieve cis-regulatory elements overlapping a genomic interval
# Example: chromosome 12, positions 111766000–111767000, GRCh38

PREFIX fantao: <http://fanta.bio/ontology/>
PREFIX dct: <http://purl.org/dc/terms/>
PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
PREFIX faldo: <http://biohackathon.org/resource/faldo#>

SELECT DISTINCT ?cre ?cre_id ?cre_name ?begin ?end
WHERE {
  VALUES (?reference ?query_start ?query_end) {
    (<http://identifiers.org/hco/12/GRCh38> 111766000 111767000)
  }

  ?cre a fantao:CisRegulatoryElement ;
       dct:identifier ?cre_id ;
       rdfs:label ?cre_name ;
       faldo:location ?location .

  ?location faldo:begin ?begin_position ;
            faldo:end ?end_position .

  ?begin_position faldo:position ?begin ;
                  faldo:reference ?reference .

  ?end_position faldo:position ?end ;
                faldo:reference ?reference .

  FILTER(?begin <= ?query_end && ?end >= ?query_start)
}
ORDER BY ?begin ?end ?cre_id

例 3

エンドポイントで実行
# Retrieve ChIP-Atlas annotations and supporting experiments for a CRE
# Return antigen names, external IDs, experiment IDs, and Q-scores

PREFIX fanta: <http://fanta.bio/cre/>
PREFIX fantao: <http://fanta.bio/ontology/>
PREFIX dct: <http://purl.org/dc/terms/>
PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
PREFIX sio: <http://semanticscience.org/resource/>

SELECT DISTINCT
  ?antigen_symbol ?antigen ?experiment_id ?experiment_link ?q_score
WHERE {
  VALUES ?cre { fanta:FCHS_104205 }

  ?cre fantao:hasOverlappedAnnotation ?annotation .

  ?annotation a fantao:ChipAtlasAntigen ;
              rdfs:label ?antigen_symbol ;
              rdfs:seeAlso ?antigen ;
              fantao:hasExperiment ?experiment .

  ?experiment dct:identifier ?experiment_id ;
              rdfs:seeAlso ?experiment_link ;
              sio:SIO_000216 ?measurement .

  ?measurement a fantao:Qscore ;
               sio:SIO_000300 ?q_score .
}
ORDER BY ?antigen_symbol DESC(?q_score) ?experiment_id

例 4

エンドポイントで実行
# Retrieve nearest-TSS annotations for CREs associated with a given gene
# Distances are reported in base pairs as stored in the dataset

PREFIX fantao: <http://fanta.bio/ontology/>
PREFIX dct: <http://purl.org/dc/terms/>
PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>
PREFIX sio: <http://semanticscience.org/resource/>
PREFIX obo: <http://purl.obolibrary.org/obo/>
PREFIX tax: <http://identifiers.org/taxonomy/>

SELECT DISTINCT ?cre_id ?cre_name ?transcript ?distance
WHERE {
  VALUES ?symbol { "ALDH2" }

  ?cre a fantao:CisRegulatoryElement ;
       obo:RO_0002162 tax:9606 ;
       dct:identifier ?cre_id ;
       rdfs:label ?cre_name ;
       sio:SIO_000395 ?regulated_entity ;
       fantao:hasTSS ?tss .

  ?regulated_entity rdfs:label ?symbol .

  ?tss a fantao:NearestTSS ;
       sio:SIO_000216 ?measurement .

  ?measurement a fantao:TSSDistance ;
               sio:SIO_000300 ?distance .

  OPTIONAL { ?tss rdfs:seeAlso ?transcript . }
}
ORDER BY ?cre_id ?distance ?transcript

例 5

エンドポイントで実行
# Retrieve FANTOM5 CAGE peaks overlapping a given cis-regulatory element

PREFIX fanta: <http://fanta.bio/cre/>
PREFIX fantao: <http://fanta.bio/ontology/>
PREFIX dct: <http://purl.org/dc/terms/>
PREFIX rdfs: <http://www.w3.org/2000/01/rdf-schema#>

SELECT DISTINCT ?cre_id ?cre_name ?cage_peak_id ?cage_peak_name
WHERE {
  VALUES ?cre { fanta:FCHS_104205 }

  ?cre dct:identifier ?cre_id ;
       rdfs:label ?cre_name ;
       fantao:hasOverlappedAnnotation ?annotation .

  ?annotation a fantao:Fantom5CagePeak ;
              dct:identifier ?cage_peak_id ;
              rdfs:label ?cage_peak_name .
}
ORDER BY ?cage_peak_id

スキーマ図

Schema diagram for fantabio
Schema diagram for fantabio